Calendar Event Loading

Incident Report for Read AI

Resolved

Service has been restored.
Posted Jun 17, 2026 - 20:05 PDT

Investigating

We are currently investigating an issue loading calendar events.
Posted Jun 17, 2026 - 17:08 PDT
This incident affected: Applications (Read AI Web Application, Desktop Application, iOS Mobile Application).